JStudio SiteWalker Service Board Forum Index JStudio SiteWalker Service Board
Find out / share information about our product, experience and requirements. To serve all user all postings must be written in English language. We are looking for constructive meanings and experience. Disrespectful postings will be deleted immediately.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Retrieved value corrupted in SQL insert statement

 
Post new topic   Reply to topic    JStudio SiteWalker Service Board Forum Index -> Product Issues: Bugs & Problems
View previous topic :: View next topic  
Author Message
TV



Joined: 06 Apr 2006
Posts: 1

PostPosted: Thu Apr 06, 2006 9:19 am    Post subject: Retrieved value corrupted in SQL insert statement Reply with quote

Hello, I created a task retrieving dynamically values from some table. At few steps I can see difference between retrieved value and value used in SQL insert statement.
Details:
Five steps retrieve five values. After the last one, SQL insert statement is run. Three of the values are decimals. For example 5.50, 1.20, 12.00. I can see these values retrieved in task run log. But in the insert statement I can see: "INSERT INTO betandwin (Kurz_remiza, Kurz_domaci, Kurz_hoste) VALUES (5.50, 1.12.000, 12.00)" Note please, that if I use only "well-working" values, whole task works fine.

If I understand the log well, I think that the value is changed somewhere between retrieving and compiling insert statement... Is it a bug, or did I do something wrong? (I can send you the task if you wish)

Thanks, Tomas

EDIT: there is no value formatting set, and other two numbers remain unchanged, although their HTML elements are identical. And another sample - value of 2.30 is changed to 2.45.30
Back to top
View user's profile Send private message
sitewalker
Site Admin


Joined: 09 Feb 2006
Posts: 39

PostPosted: Mon Apr 10, 2006 7:21 am    Post subject: Please send Reply with quote

Hello Thomas,

we tried to reproduce this behaviour, but were not "successful" so far. Please send the Task - as offered by you - directly to our support eMail address on service@jstudio.de. Also specify the name of tables & collumns completely to rebuild a test database. We are interested to check out the problem.
What DBMS you are using ?

Best regards,

Frank
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    JStudio SiteWalker Service Board Forum Index -> Product Issues: Bugs & Problems All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group